Redundancy doesn't work!

#1

I have the redundancy set in my client’s Servers.
In the Master Gateway says :
Redundancy
This system’s mode is master and it is currently active. The project state is good.
The peer system is: connected from 192.168.0.3
Click here to force fail-over to the backup
Click here to re-sync configuration

And the same in the Backup Gateway:
Redundancy
This system’s mode is backup and it is currently non-active. The project state is good.
The peer system is: connected from 192.168.0.2
Click here to force fail-over to the backup
Click here to re-sync configuration

Apparently the redundancy is working, in the status page, shows me the correct overview map, with the Master active and the Backup cold.

When I click in the “Click here to force fail-over to the backup“ link, the Master Gateway gets cold but the Backup Gateway never gets active, and the Message that should show in the Client is not the correct one. It should show that the connection with the Master Gateway is faulted and connecting to the Backup, isn’t it? But only show the first line, that can’t access to the Master Gateway.

I don’t know when I went wrong when I set up the redundancy, the only thing that I haven’t try yet is restart the Gateway. I’m waiting to the plant to get in a process that is not a dead or alive situation not to have the SCADA running.

If anyone can tell me another solution, I’ll be very much appreciated.

0 Likes

#2

Make sure port 8750 is open, and try forcing the bind address/HTTP addresses used for redundant communication on both sides. Clients might not be getting the correct address to attempt to connect to if the master goes offline.

0 Likes

#3

It shows Peers missing both master and backup in Version: 8.0.2 (b2019060511)
image
image

Settings on backup
image
I’ve read links [https://docs.inductiveautomation.com/display/DOC80/Setting+Up+Redundancy](http://Setting Up Redundancy Doc) and [https://www.inductiveuniversity.com/videos/setting-up-redundancy/8.0](http://Setting Up Redundancy Video), but it just doesn’t work
Please help me out to make it work

0 Likes

#4

The gateway network port can’t be the same as the port used for the web page and client connections.

0 Likes

#5

Finally, with these two steps it’s working, thank you @pturmel

  1. Setup backup node setting on both sides (I think setting up it on backup server only is OK enough)
  2. Approve your backup node on master server’s gateway network incoming section
0 Likes