Remote Access to Gateway Webpage

This is likely a very easy question but I’ve not been able to figure out how to resolve the issue.
I have an Ignition 7.9.6 install on a VM on a development vCloud. I can remote into the server using Remote Desktop (Windows Server 2012 R2 on the server and Windows 7 on my laptop). When I type the “http://:8088” into IE on my laptop I get the “This page can’t be displayed” error. Am I missing a Gateway setting to allow remote access to the web page? I suppose this could be a network issue where our IT folks are blocking port 8088, but I wanted to get some feedback from the Ignition Community before I went down that rabbit hole!

Edit to add: I did turn the Firewall off on the server with no joy! :frowning:

Thanks!

1 Like

If you are running the browser IN the remote desktop session try
http://localhost:8088

Sorry! I was assuming everyone could read my mind. :frowning:
I’m trying to open the web page from my laptop.
The reason is that our vCloud environment has very limited resources and people throughout the company use these VMs for development. I keep getting low memory warnings and wanted to try to run the designer from my laptop to reduce the server side load a little at least.

Thanks for trying to help even when I’m negligent in asking a simple question! :slight_smile:

To further clarify, I want to run the Designer on my laptop. I was trying to access the Gateway Web Page from my laptop to launch the Designer from there. If there is a way to launch the Designer without accessing the web page that would be helpful also.

You need to find out what the IP address or hostname of your server is, then use http://10.10.10.10:8088 replacing with your host or ip of course. You should have that info if you can remote desktop in.

I know the IP and that is what I’ve been trying to use but get the error. As mentioned, I can connect to the server via MS RD (using the IP). Also I can ping it. When I use the “Fix connection problems” button on the error page it does indicate that it sees the server but that it isn’t responding. Here is that message, “resource (xxx.xxx.xxx.xxx) is online but isn’t responding to the connection attempts.”

I’m still hoping someone has a “non-IT involved” solution, but that hope is fading!

Thanks.

Designers and clients connect to the gateway using HTTP to the same address and port as you use for the gateway web interface. If the latter doesn’t work, the former won’t work either.

Windows Remote Desktop uses port 3389. Ignition uses port 8088 (and 8043 for TLS).

If you can RD into the server but can’t connect directly to the gateway from outside, then I’d say something is amiss in your network configuration (port not forwarded somewhere, hardware firewall blocking connections, etc…)

OK, so it looks like I’ve checked everything (at least those things that you all have mentioned) on the server and client sides which leads me to believe it’s time to jump into the IT rabbit hole - always fun!

Thanks!

1 Like

Sounds like you need to open port 8088 to public traffic on your cloud machine.

On remote server:

  1. Click start and search for “Windows Firewall with Advanced Security”
  2. Select “Inbound Rules” in the left pane
  3. Select “New Rule” in the right pane. A wizard should pop up
  4. Select “Port” and next
  5. On the next screen, make sure TCP is selected and 8088 is entered into the “Specific local ports” box and next
  6. Select “Allow the connection” and next
  7. Leave all boxes check and next
  8. Give it a name like “Ignition Inbound” and click finish

You should now be able to visit http://xxx.xxx.xxx:8088 and access the gateway.

After this is done, you should see your rule in the Inbound Rules list. You can double click it to edit other properties including what IP ranges can access that port.

Hope this helps.

7 Likes

The issue isn’t in the firewall settings at either end. I’ve already done what you suggested, one of my first steps actually. I even temporarily disabled the firewalls on both ends. It is most likely, as previously state, configuration in our IT hardware that routes between the various subnets/VLANs.

Thanks all the same.

Initially I had the same problem with an Ignition installation on an Azure cloud VM. Turns out, in addition to opening up the port on the VM’s Windows firewall (see Feb23 reply above from salbrechsen) the VM runs within a virtual network which, by default, ONLY has the RDP port 3389 open. So, you’d go to your Network Security Group settings and add an Inbound security rule for port 8088 which will then open things up a bit for Ignition. Of course, next you’ll get an advisory warning that you have paths exposed to the internet and you should really use a VPN or private connection… but that’s a topic for another day.

1 Like