Remote Tag Bad Access

What I am I missing here? I am trying to setup a remote tag provider between two gateways that are both running 8.0.4. Here are the steps I have taken and every time I try to write to the tag from the remote gateways designer I get a Bad_Access error box.

For this example I have gateway A that has an internal tag provider called tagsXYZ. Then I have gateway B that I would like to be able to write and edit tags on gateway A’s tag provider tagsXYZ.

Here are the steps I am taking

  1. Create gateway connection outgoing from gateway A to gateway B.
  2. On gateway B accept the gateway conneciton from gateway A. Everything looks good. both sides say the connection is running.
  3. Create gateway connection outgoing from gateway B to gateway A. I dont think this is needed, but hey couldn’t hurt. same as above but reverse gateways.
  4. On gateway A create realtime tags with a standard tag provider called tagsXYZ.
  5. On gateway A create a security zone called zone1. In Identifiers->Gateway Names put gateway B’s name in there. Check all the boxes under Qualifiers, req secure sconnection, direct connection, etc.
  6. On gateway A go to Service Security and click edit next to zone1. Go down to Tag Access and next to Access Level:‘tagsXYZ’ set the drop down to “ReadWriteEdit”
  7. Go to gateway B and create a new realtime tag provider of type Remote Tag Provider. Select gateway A, choose tagsXYZ, name it tagsXYZ
  8. Open designer on gateway A, open tagsXYZ and add a new memory tag of integer type, make sure security is set to ReadWrite
  9. Open designer on gateway B, set communication on designer to ReadWrite, open tags XYZ, browse to new memory tag, type in value 1, press enter.
  10. Receive Bad_AccessDenied error box

I just got back to trying to figure this out from yesterday. First thing when I opened the designer I tried writing a value and it worked. Then I right clicked the tag and now the edit tag option is no longer grayed out. I guess it just needed a break for the night to start working.

Now that you mention it, I think I’ve run into either a delay or server restart for some settings like this to go into effect too. Glad it’s working for you now.