Renaming folder loses tags. Cannot rename or delete folder. Cannot create new tags or folder

I encountered a problem today. Imported some tags via JSON to create a new sub-folder and tags. This all worked fine and tag values were updating.

As the new sub-folder had the same name as the parent folder, I renamed the sub-folder by adding “_Alarms” to the end of its name. However, when I expand the sub-folder, all of the tags have disappeared.

I tried to rename the folder back to the original name but when I press enter to input the sub-folder rename, the name goes back to “xxx_Alarms”. No errors are shown.

When I try and delete the sub-folder I get the error “Bad unknown”.

When I try and import via XML again it starts the import process and when it reaches the “Reading tags…” step the progress bar seems to be stuck. After a long time, I get a long list of errors including “Bad_Failure - tag already exists” and “Bad_NotFound - Parent tag not found”).

If I try and create a new sub-folder with the original name (e.g. PLC1) it creates a new folder but automatically renames it PLC2.

It’s like the original sub-folder still exists in the database, but is not being displayed on the tree view.

Any ideas on how to resolve? I don’t need to keep any history. I can delete tags, folders if required.

Try restarting your tag provider from the gateway webpage. I raised a bug report for this a while back, can’t remember the status of it, I’ll link it in here when I have time.

@gavin.strack Are you still seeing this? What version are you using?

I’ve restarted the device connections and OPC server. No effect. The problem continues. No response from my tech support ticket either.

The workaround I’ve been using: Import your tags into a random junk folder, copy whatever you imported and paste it somewhere else, then delete the original import. I have all sorts of issues with the imported folder, but a copy of it seems to work fine.

The only way I’ve found to fix the imported folder that’s all messed up is deleting the parent folder that contains it.

Did you try Nick’s advice to restart the tag provider? I wouldn’t expect restarting the OPC server to help this case.

1 Like