Reorder Pens in the legend?

I added in a few tags(7) into an easy chart. One of the middle tags and the last one need to be at the top. How do I reorder the tags with out deleting and starting over?

I would open the tags tagPens dataset, export to the clipboard to edit the order of the rows, then paste it back.

I may have no worded it correctly… maybe the picture will help… i want this “pen” to be where the blue arrow is… with out deleting all of the other tags…
image

Did you try Phil’s suggestion?

What I suggested would not delete any pens. Pens set up by drag/drop or by the chart configurator end up as entries in either the tagPens property or the pens property, which are datasets. Datasets can be sent to the clipboard, edited externally (like changing row order), and pasted back in.

{Ah, typo s/tags/tagPens/ }

Umm… that sounds like there is code involved with that… I do not know how to code nor would I know where to look :confused: … so you are telling me it is possible, but I will need someone’s help… cool… I can handle that.
:slight_smile: I’m new and trying to fumble through what I can and can’t teach people(others at my facility) once we get that far… thanks for the help.

No code involved.

In the properties for your EasyChart component scroll to the bottom. There is a Tag Pens property. This is a Dataset of all of the tags which have been added to the chart. Select the icon that looks like a table with a magnifying glass on it, this will bring up the Dataset Editor.

On the right hand side of that Dialog, there is an icon that is an arrow pointing to a clip board, click this and then paste it into your favorite editor (Notepad, Notepad ++, etc), reorder the rows as you want them, copy them back to the clipboard after you have re-ordered them how you want. Then using the same dialog, paste them back into the Tag Pens dataset.

I actually tried this, and it didn’t work. Maybe i am doing something wrong, but the easy chart pen order did not reflect the re-ordered tags after editing.
image

Yet:
image

Edit:
Im a dummy, you have to uncheck order pens, then it works just fine.

where is order pens???

Use the copy button, then paste it into a text editor of your choice.
This is my test dataset, just reorder the last three lines in this example:

"#NAMES"
"NAME","TAG_PATH","AGGREGATION_MODE","AXIS","SUBPLOT","ENABLED","COLOR","DASH_PATTERN","RENDER_STYLE","LINE_WEIGHT","SHAPE","FILL_SHAPE","LABELS","GROUP_NAME","DIGITAL","OVERRIDE_AUTOCOLOR","HIDDEN","USER_SELECTABLE","SORT_ORDER","USER_REMOVABLE"
"#TYPES"
"str","str","str","str","I","B","clr","str","I","F","I","B","B","str","B","B","B","B","I","B"
"#ROWS","3"
"New Tag 1","[~]New Tag 1","MinMax","Default Axis","1","true","color(85,85,255,255)","","1","1.0","0","true","false","","false","false","false","true",,"true"
"New Tag4","[~]New Tag4","MinMax","Default Axis","1","true","color(85,85,255,255)","","1","1.0","0","true","false","","false","false","false","true",,"true"
"alarmTag","[~]alarmTag","MinMax","Default Axis","1","true","color(255,85,85,255)","","1","1.0","0","true","false","","false","false","false","true",,"true"

Then then paste it back in with the button right below the copy button shown in my screen shot.

Oh, my bad, it’s really sort pens
image

Got it… thanks :slight_smile: worked perfect