Report Export copies the columns for every page

When making a report that gets saved as a csv, I’m getting this issue where it reads the headers more than once, how would I go about getting around that?
EDIT: I want it to show up at the top of every PDF, but not in the CSV. Is that possible?

1 Like

Bump. I have this issue as well

You could try running your report in a script using system.report.executeReport with a filetype of CSV.

Then use regexes or string operations to delete all but the first header.

I haven’t experienced this issue though. To my knowledge the CSV should contain only that data you see in the report XML on the Preview tab.

If the report spans a number of pages though in the preview, the column headers are repeated on each page. There doesn’t appear to be an option to remove this.
I think the simpler option, unfortunately, might be to just use scripting to convert the dataset to CSV format and write this to a file using a gateway script or a transaction group trigger.

And you can accomplish that conversion with executeReport. Which still accepts parameters and fires any preprocessing scripting events.