Report Not Displaying SQL Values

I need help! Does anyone know why I am getting <N/A> error in my “DowntimeMinutes” column of this report:

As you see from the screenshot the Dataset Viewer does display the column values of “DowntimeMinutes” but when I run the report I get the <N/A> in this column!

Here is the script that I am binding the table to:

Here is the report designer data:

Any advice is greatly appreciated.

I am using Ignition 7.7.2 (b2014121709)
MES_2015-02-16_2054_partial.proj (66.4 KB)

If you export the window with the report and dataset filled and attach it to this forum thread I will take a closer look at it and see if I can find out why the DowntimeMinutes says N/A.

Sometimes the report viewer can be tricky.


Have you accidentally set a format for that column.

I just tried for example, set a number to date format and it displays N/A.

I exported the window and also data I was using in the SQL server. See my post for the additions.
DatasetExportedfrom SQL.csv (7.24 KB)
MES_2015-02-16_2054_partial.proj (66.4 KB)

I took a look at your window.

craigb is correct. The reason the column says N/A is because the format for the @Downtimemin@ variable is set to a date format. The format needs to be changed to numerical format

You can change it by double clicking on the text “@Downtimemin@” to make it highlighted. Then in the top right of the report designer select the “Format” tab, then select the “9.99” button. Then select a numerical format. And that is it, press the “OK” button at the bottom of the report designer.


Is there something wrong with the timestamp columns also? Look at the funky dates in there!

Thank you craigb and nmudge. You were correct; I was using the wrong format. You guys are great…
Thanks again!

You are welcome!