Report Query Read Timed Out

I’m getting a read timed out on some reports that were previously working fine. I ran the query in the query console and the results return instantly. Unless I’m not understanding the start and end day I think I ran retrieved the same data. I tried increasing the read timeout from 60 to 240 seconds which did seem to increase the timeout but the report still timed out. Any ideas out there on this one? I’m new to reports and trying to figure out the issue with this report create long ago by my colleague.

select res.dataday, rtl.reporttagdesc, res.StartCounts, 
		res.totalOnTime, res.avgOnTime, res.minOnTime, res.minOnOccur, res.maxOnTime, res.maxOnOccur, 
		res.totalOffTime, res.avgOffTime, res.minOffTime, res.minOffOccur, res.maxOffTime, res.maxOffOccur, rtl.TotalPumpsAtLiftStation, 
		res.avgOnTimeSec, res.avgOffTimeSec, res.minOnTimeSec, res.maxOnTimeSec,
	from report_tag_lookup rtl inner join
	report_equipment_summarized res on rtl.ReportTagId = res.ReportTagId
where res.DataDay >= ? and res.DataDay < ? and = 'Equipment'
order by rtl.ReportGroupOrder, rtl.ReportTagOrderWithinGroup, res.dataday