Report Simple Table Gridlines

How do I get rid of the gridlines in a Report Simple Table? You do it with the Stroke “hidden” setting on a regular table. This does not work on the simple table. Setting opacity to zero hides the contents too which I don’t want to do.

Yikes, that’s not good. I’ll make a ticket to get this fixed.

Any word on this?
I’m seeing the same behavior in v7.8 (reporting module 3.8.5 (b2016120813)) and v7.9 (reporting module 4.9.0 (b2016101208))
Setting the stroke color to white on the whole table or individual cells also seems to have no effect as the borders are still drawn. .

Not surprising that you’d see that behavior in those versions, since they were both released at least six months before the conversation above. I don’t see it in the currently open tickets, so you might want to download the latest version of 7.9 and test it.

I just upgraded this gateway to Ignition v7.9.5.20171116-1516 w/ reporting module v4.9.5 (b2017111623) and it appears to be behaving the same way.
Even if you select the line individually and set its ‘visible’ property to False, it appears to be grayed/transparent in design. Then switch to Preview it is still drawn.
Curiously, when you switch back to Design, the ‘visible’ property is set back to True…

Any word on this? I’d like to use the simple table to align things in reports but not print the cell lines.
It seems ‘stroke’ and ‘visible’ are both affected.

Its a simple ‘workaround’ since the align functions are burred in menu as opposed to being on their own toolbar as in the rest of ignition (of course a toolbar would be preferable but there are still times the simple table would be handy!).

It’s in our queue, but we have a lot of things in the queue. :slight_smile:

Any update on when this will be addressed?

Select each line individually then change the ‘Stroke Style’ property to ‘Hidden’ just solved this issue for me.

I’m having this same issue with 7.9.14, cant hide the border

Using 8.1.1 nightly and I’m seeing the same issue. Any update on when this will be corrected?

Selecting individual lines allows the Stroke Width to be changed in the Property settings and Design, but Preview continues to show default line with. Additionally, Height / Width entered into the Property settings are overwritten by the previous sizes based on the last drag / drop position.

2 Likes

For posterity, there’s a few different things going on here.
First, the reporting engine we use automatically inserts the dividers, and it’s not really feasible to style them individually (for instance, dividers are shared between adjacent cells, so which cell’s formatting settings would ‘win’?)
Second, there are some properties that control (per-cell) whether it will render its dividers…but they weren’t explicitly exposed to the end user.

Right now, what you can do to manipulate the dividers in a simple table or crosstab is change the ‘Style’ at the top level:
image
It defaults to ‘None’ (which is wrong), but if you change it to some other value, then back to None, your table will not have any visible dividers anymore (you can try using the other styles to control your dividers as well).

In 8.1.12, each cell will have its individual top/left/bottom/right divider properties exposed, so they can be manually changed in the property inspector.
You’ll still need to jump through some hoops (such as disable the right divider on cell A, and the left divider on cell B) to hide the dividers, but you’ll at least have full flexibility.
In terms of more exotic styling, you can (as you always could) configure each cell with its own border, fill, and other styling; it’s just now a lot easier to remove the automatic dividers you don’t care about anymore.

1 Like