Report table showing repeated data rather than what is in the dataset

So I have a dataset that a report table component pulls information from. However, it frequently will show repeated values in certain rows. I can’t even figure out a pattern as to why. You can even see that the data is correct in the XML that pops up when you preview the table or by binding the dataset tag to a table component in a window. It occasionally works, usually when the dataset is larger. I cannot figure out what could be causing this.

1 Like

At a minimum, we’d need the version of the reporting module and a screenshot of how you’ve set the report table up.

Another one here.
Reporting version : 4.9.10 (b2018112813)
we used a table group with parent-child tables.

Report example:

In your case, the key’s in the table don’t look quite right (I’m making some assumptions about the data source, based on the image). I would imagine you don’t need the name of the data source in your keys. Can you try changing the keys so that they don’t contain the data source? E.g.:

@Consumption By WorkOrder.PIN@ changed to @PIN@
Consumption By WorkOrder.GRADE@ changed to @GRADE@
etc…

2 Likes

I have more than one data source, so, I believe, it is required. Especially since this reference was produced by Drag&Drop.

UPD:

I fixed my issue by using basic sorting of a column that may have repeated values. I’m not sure how the table component parses through data sources, but it appeared that once it reached a value that was the same as the previous row it would overwrite every column after that with the same value as the previous row. I would end up with the correct values in the first two columns and then the rest of the row would be identical to the previous. I sorted them by my “startTime” in the data source, which had the same value for multiple rows and it appears to have solved my issue. I’m not sure what about the table component could be causing this though. The strangest thing is that the data is always correct when you view the XML code that pops up when previewing.

1 Like

Right, but if you dragged and dropped the keys into the text shapes before assigning a data key to the table, you’ll end up with the notation in your screenshot. If you try dragging and dropping now that your table is assigned, is it using the same notation?

Side note, I’m still not certain what the data source(s) look like, so this is mostly speculation based on the image you provided.

I’ve updated my previous reply with data source list and table group arrangement.
Here is the evidence of duplicated rows and correct XML data.
Sorting the data source by WorkOrder (unique key for this table) did not help.
Report file was emailed to support, ticket 86307.

1 Like

Scott,

Originally I thought that yr hint is not relevant, because keys were generated by dragging from DataSource, but removal of the prefix has actually fixed my problem.

Thank you!

2 Likes