Reporting 7.8 date error

I’m getting the following warnings when running a report.

WARN: Ending date {StepFinish} for tag history in report Report could not be parsed as a date.
WARN: Using Historical date range, but could not parse {StepSTart} in Start Date field.

The query is a historical tag query nested in a SQL query. The parent returns start and end times for a batch, and the historical query gets the temperature during the batch time. StepStart and StepFinish are columns in the parent query.

The interesting thing is that the report gives the desired graph with correct start and end dates.

I’m not having much luck replicating this.

What version of 7.8 reporting are you running (including build number)?

How is your StepStart column defined in the database? (Date? Timestamp? Datetime?)

7.8.0 (b2015101414)


I see 7.8.1 is released today. I’m going to install that and see if I get a different result.

Still not able to replicate it with 7.8.0. If you still have issues with 7.8.1, you should contact support, since there seems to be something going on here that’s particular to your set up that I’m not seeing.

Same result with 7.8.1. I’ll contact support.

I’m also experiencing an error in the viewer. My report is 10 pages, but when I scroll in the viewer, page 2 of 10 is identical to page 1. All 10 pages are. When I save to pdf, I get the expected 10 pages of report.

I am having the same date issue. Was there a resolution? Thanks!

It turns out my problem is that the parent dataset contains Null values for DATETIME if the step hasn’t been started or finished. So, the reporting software is correctly reporting a failure to process the child query.

My issue is that I need to generate the report while the batch is in process. I’d like to not return errors, but empty graphs, or even no graph.

I haven’t gotten to looking for a solution to that. Kathy, is there a way to suppress the error messages?