Reset Trial Not Permitting New Perspective Session

Hi, I was working on my Perspective project yesterday using the trial mode activated from my laptop’s browser. This morning, I tried to enable the trial from my phone’s browser. After starting the trial, however, any perspective sessions continued to direct me to ‘activate a new trial’. Following two hours later, I tried activating the trial from my laptop browser, but continued to have the issue. When I try to get start a new session and I get the attached log data. Has anyone else had this issue?

Gateway version Version: 8.1.15 (b2022030114)

It seems like there’s something preventing the websocket from connecting between your gateway and your devices, and that error is (potentially) being erroneously displayed as a trial related error instead of the actual cause.

You can take a look at what those logged warning messages from WebSocketChannel are saying in the stacktrace; there might be an inner exception that’s more useful. You can try the classic IT solution, restart the gateway (and the machine it’s on?). If that goes nowhere, I’d start investigating the firewall.