Resize power table without resizing rows

I would like to resize a power table with a script so it only takes up the bottom half of its current space on the screen, leaving room to make other components visible in the newly available space. I’ve tried it using system.gui.transform, but I have found that when I change the height of the table, it shrinks the text of the rows as well. So I go from this

to this


The rows appear to be the same height, it’s just the text that has shrunk. I had hoped I could just reset the font after the transform finished, but it’s 12pt Dialog, Plain before and after.

Is this a bug, or is there another step I should be taking here?

Here’s the script I’m using for this

ptHeaders = event.source.parent.getComponent('ptOrderHeaders')

oldY = ptHeaders.y
oldHeight = ptHeaders.height
verticalShift = oldHeight/2

system.gui.transform(ptHeaders, newY=oldY+verticalShift, newHeight=oldHeight-verticalShift)

Another piece of the puzzle: when I do this in the designer, it does not shrink the text of the rows. It only happens when I transform the power table in a launched vision client.

Just in case anyone else ever runs into this, I did figure out the problem. The Power Table had its Auto Row Height property set to true. As soon as I set it to False (and set the actual Row Height property to be the same height as when auto-sized) it worked as I would have expected, with the rows all staying the same height while the table itself shrank.

This does lead me to another question: when a table’s rows are auto-sized, is there a scripting function which would tell me what height it had set the rows to?