Resolution connecting Omron CJ2M to Kepware and then Ignition

I am just posting a resolution (hopefully it might help someone to troubleshoot)
I have an Omron CJ2M CPU31 who was not even online. I couldn’t go online with the CX-Programmer v9.54 from my desk using the WiFi network. I could only go online by connecting my laptop to the CJ2M with a USB cable:
So I had to make that first change: I will have to assign an IP address to my PLC


Make sure the rotary switches are correct, if not power down the PLC and correct those switches (after correcting it might give you an error). Note, for this process you don’t need to Download the program to the PLC…just connect via USB to PLC

Make changes to setting:
Transfer to PLC (Notice: PLC will turn off and ON automatically after this button is pressed), then it will ask you that you have to manually TURN OFF the PLC. Say okay, and Turn off the entire PLC Cabinet. Then turn it back on again after 3 minutes. It should have the correct settings now. Check again by connecting to the PLC via USB.
Note: Notice my Subnet Mask: 255. 255.252.0 This has to be the way in my case. The Default Gateway Address has to be correct, if you’re not sure check this with IT.

See, the 17 above, that one has be 17 because of this:

Once you have success going online with there program through WiFi, you will need to download the Kepware Demo: from this website:

It is 2 hour demo of this product. But, you can also reset the 2 hour timer as many times as needed. Use this link, https://my.kepware.com/mykepware/Landing.aspx, please note you will have to login to (or create) the “My Kepware Account” portal first.

Once you are running Kepware, you can create a new channel by clicking on the highlighted icon:

Then, select your device. In this case, Omron FINS Ethernet:

ID is the IP address of your PLC


On the admistration icon, make sure you have this one checked:d

Go to the properties of the Chanel (in this case Channel 2) where you added your device PLC, and make sure about the IPv4 address of your computer is matching the Network adapter on Kepware, otherwise tags will not be read and it will say “Bad” on the Quality of the tags:

Also, if you have Kepware installed in another Virtual Machine, make sure you have set up the TCP connection on the Network Adapter (and not on “Default” or “local host only”). You might also need to configure DCOM Settings (microsoft securty for remote connections) on That Kepware VM and make sure there are no local security policies in place which would prevent the connection.

In properties of the PLC device on Kepware (channel 2), right click and make sure you have the last octet of your source node which is the last octet of the IPv4 address of your computer and the 204 is the last octet of the PLC:

Also, check this link for another important detail:
Make sure you change the “Allow anonymous login” from "No to “Yes” :

Go to OPC UA and on the Client Sessions I change the “Allow anonymous login” from "No to “Yes” :


Then, after I hit apply and okay, I selected REINITIALIZE on the administration icon

On Kepware, on the administrator icon located on the task-bar, you need to re-start the approximately 2 hour trial by stoping and starting runtime the service:

Then, once you launch the Quick Client:

You will notice that the approx. two hour trial expired by opening the Quick Client and looking at the tag _System._TimeLimited Features under the _System tags:
As an example, the picture below shows the value on brackets for the _System._TimeLimited Features tag and the Update Count at 1 (not increasing or decreasing). This means the Tags from your devices are not updating anymore (although the tags kept the last value they saw) and it is time for stoping and starting the Runtime Service:


Once you stop an start the Runtime Service, you will see:


Now, Since in this case we are using CX-Programmer v9.54 you might experience that everytime you are running Kepware, it will automatically will take you offline on the CX-programmer. That is because we are connecting via Ethernet and not Ethernet(FINS/TCP), So we need to make this change:



Now, we need to export and import the tags on Kepware, because we need to fix those tags that are broken: Most likely wee need to correct the Omron Data Types: Check out this document on page 88 for CJ2 Addressing:
For example, I had to correct these highlighted tags:

Now, that they are corrected by adding CIO in front of their address:

Go head and import your tags again in Kepware, and…
Finally, connect to Kepware following Ignition video Tutorial:

PS: If you have Kepware in a VM, and you are trying to connect multiple Omron PLCs to it. Maybe might been successful in connecting the first Omron PLC since the UDP port by default is set to 9600. Now for the second and third, and so on… The UDP port need to be different, such as 9601, 9602, and so on… Kepware uses the UDP driver not the TCP. Therefore, the TCP can stay the same in all of them, such as 9600 in all.

For example, on my next Omron PLC, I have the following settings in Kepware:

And on my PLC, CX programmer, I need to go to Program Mode, Go to the IO Table, double click on the Ethernet card, change the UDP port, Then,
Transfer the new settings to the PLC with the ‘Transfer PC to unit’ button’ >
Finally after the PLC had re-started, it might not be necessary, but it might be best to power cycle the PLC:

4 Likes