Resolving dependencies failing, connection refused

Hi all,

I just installed Ignition 7.8 and started to go through to Ignition SDK documentation. I followed these instructions here: and tried to run the examples. For some reason I was not able to build the projects. I’m using NetBeans 9.0 and I tried to build the project with dependencies. I got the following error message:

Failed to execute goal on project atd-gateway: Could not resolve dependencies for project com.inductiveautomation.examples:atd-gateway:jar:1.8.0: Failed to collect dependencies at com.inductiveautomation.ignitionsdk:ignition-common:pom:7.9.3: Failed to read artifact descriptor for com.inductiveautomation.ignitionsdk:ignition-common:pom:7.9.3: Could not transfer artifact com.inductiveautomation.ignitionsdk:ignition-common:pom:7.9.3 from/to releases ( Connect to [] failed: Connection refused: connect -> [Help 1]

Also ‘mvn package’ command fails. It looks like I can’t access the Nexus repository. Any idea, what is going wrong?

Thanks in advance and regards,

  1. IA’s nexus server is known to be having problems lately, and
  2. Why in the world would you install the no-longer-supported version 7.8?
1 Like