Right clicking now does nothing for template inside a docked window?

Refactoring some windows to break down big Main Windows with repeating components into a big header with the common components and smaller big windows for the different components.

Part of this was putting a template of a tree on the big header window tree. However, now when I try to right click inside the tree (our normal way for opening up popups that add entities to the tree), the popup menu no longer appears. However, on a window that we have not got around to yet which still has the tree template on the main window instead of the big docked window, right clicking works as expected.

Is right clicking disabled in docked windows? Is there something that can explain this?

No other click handlers anywhere? Swing only allows one click handler to intercept an event, unless you go out of your way to pass them through.

No scripts on the root container, no invisible boxes on top of my tree, no custom change script on the template instance of the tree

At a loss. I haven’t tried to recreate this but I think it would be simple in case you want to see if it’s a more general thing

  1. Make a template with a tree object
  2. On the tree object set up a mouseReleased property that opens a popup menu

Seems to work when its in a main window but not in a docked window.

I think I might call support though as I am at a complete loss and don’t see anything that could be intercepting my clicks here.

Well, I don’t know how helpful this is, but it worked for me.
I put a mouseReleased event handler on a tree view inside a template. I put that template in a docked view. I launched a client, and the handler is firing when I click in the tree view.

I know sometimes things get stuck when copying/pasting so I made a new instance of the template in the header, and then on the main window as well and none of them are firing either

But on my other big Main window, both instances do work

So it does not seem to be anything with to do with main windows or docked windows necessarily it seems.

Thanks for testing. I’m going to call support as something very weird is going on that I can’t figure out.

No Ignition error here, just a programmer’s mistake of hiding control flow logic in the database and not following certain other standards. I was able to make it work.

1 Like