Rockwell DF1 using Moxa EIP3170

I have a Micrologix 1100 and I’m using the DF1 port with default settings to connect to a Moxa EIP3170.

I can successfully connect via the Moxa using rsLinx and can program etc using RS500.

I can’t seem to get a connection using the Ignition drivers, status just reports “Determining Protocol”
Previous posts seem to indicate that there has been success, any ideas?

Have you tried disabling browse in the driver config under advanced?

Hi wking

I’ve tried both disabling/enabling the “Processor browse” option and “Zero TNS Connection” option

I would take a wire shark capture from server and see what is going on. In particular what the response packets from the device looks like. If you know you have the switch configured correctly. Is this switch doing 1:1 NAT translation? Like private IP to Public IP.


Theres no switch, its just EthernetIP to DF1 connected directly to the Moxa to eliminate any other complications.

Oh gotcha. My bad. I thought you were going through the ethernet port. I should read more. Inside the moxa app there are tools to look at trafic, com mapping and what not… maybe that could clue you in.

Any luck with this?

Also trying to get connected to a SLC 5/04 using a Moxa EIP3170 and the Allen-Bradley SLC IA driver.

Ping @Chris_Taylor now he will get a notification :slight_smile:

We did get it working but I can’t remember how, I’ll run up the project in a VM in the next few days and let you know

1 Like