Roles with space in name

On 7.7.4 64bit Linux Headless

If there is a space in name of role it will not let you select it in required roles for a project. Its in the list. If you select one with no space it will green up, with space no green up.

If you pick a role with no space first then one with a space it will be good also.

Not sure what was causing it, Sorry. I looked at all my authentication settings, nothing changed. Reloaded the project, and it started accepting a space again…Strange.