Root Container background color stuck

I have a vision app. I changed the background color of a window’s root container a few days ago. People did not like the color and I have tried to change it back. No matter what color I put in the background was going to dark grey. I was able to put it back to the color that was rejected by using undo but after I tried binding background color to a condition I can no longer get back to any other color. No matter what I set it to there is no change. It is stuck on a very dark grey. Other windows are not doing this.

Just to confirm, did you remove the binding for the background color?

Yes I did. Additionally, I just had some success. When I originally changed the color I used the wheel and associated slide bar. Now when I change the color by any other means I need to open the wheel and move the slide bar from 100 back to 99 or lower. For any color I set it to by another means 100 on the wheels slide bar makes it dark grey.

I haven’t seen anything like this on 8.0.2–not sure if upgrading would help you, but now that 8.0.2 is the current stable release I’d give it a shot. As expected, some bugs were introduced in major version 8 and each minor release squashes a few.

I just updated to 8.02. No change.
Just to be clear, the color in the properties window does change to whatever I want, the background color of the root container does not match that however until I open the wheel and slide the bar to 99 or lower. Then they start tracking together until I make a change using some other method. It’s an okay workaround unless I need to link to a property which I would like to do.

Do you have the same problem if you create a new window and try it there, or is it just in this instance–the latter perhaps suggesting something got corrupted?

It is just this window.

In that case I’d copy contents of window to a new empty window. Rename the old one to something like name_old and rename the the new one to the name the old one had. If everything works, delete the old one.

I am having a similar issue when copy pasting a group of components over (currently using Ignition v8.0.9). When I ungroup them, add a component in, and then regroup them, the background will not go back even though the rgb is set the same.

I did as posted above and moved the scale from 100 to 99 and that worked by adding 252 to the end of the rgb (so full value was 221,221,221,252 in my case). If I deleted out the 252 or pushed it to 255 then the background color goes away again. So for now I have placed it to 254 for final value of 221,221,221,254 in my case.

Will this be resolved in one of the upcoming releases? I don’t see anything in the release notes for 8.0.10 RC1. Thanks.