Root container opaque

I tried setting my root container opaque property to false so it would just show through to my client background color, but it just shows grey. is it possible to make the root container opaque?

Thank you,

What version of Ignition are you using?

Setting opaque to false should give the container the same background color as the rest of the window.


That was fast.

Do you have any bindings on the container?

no here is a picture of a brand new window you can see in the designer. on the left you can see the grey window/rootcontainer and to the right of that you can see the client back ground color. there are not any bindings on the window or root container. I would expect to see through the window and only see the green client background color.

Ok, now I see what your trying to accomplish. Currently, there is no way to do that. The only way that you would be able to make that work, and it probably wouldn’t look very good, is if you set the root container of the window to the same color as the client background color. If you place the container component on a window, the opacity function works in the way your trying.

yes that is currently what we do. all are windows have a background color matching the client background. I was thinking for the future we could set all the windows to opaque and if we wanted to change colors we could just change the one property setting for client background color.

Talking to Travis, he said there is a way to do this, but it will take some work. There is a post in the forums in regards to this, I will try to find it and post up a link. Also, make a request in the feature request section.

As per this post, try setting your root container opaque property to false and put the following code in the window’s visionWindowOpened event:window = system.gui.getParentWindow(event) window.setOpaque(0) If you’re just wanting to be able to set the background colour of all windows in one place, I would bind each window’s background colour to a client tag and allow the user to change this.

Confirmed. Thanks AlThePal.