RSLogix 5000 Strings

How do i get strings from a RSlogix 5000 PLC to properly display in Ignition?

The translation seems to be a bit off between the driver and the PLC.

When I try to add a string tag from the RSLogix PLC it creates a folder for the tag, data folder with the array of SINTs that make up the string and a length tag. Is there a trick to doing this?

I’ve attached a screen shot.

Thanks

I need to verify this with Tom, but I’m pretty sure the driver only supports the built-in String type. Custom defined strings are indistinguishable from any other UDT to the driver.

I’ve also tried just a standard string and it does the same thing.

What version of Ignition / AB module are you using? I’ll take a look and make sure nothing has changed… standard Strings should work.

7.6.3-rc3 (b2013081216)

OpcCom 1.6.3-rc3 (b2013081216)

Hmm… wait a sec. Where are those tags coming from? An OPC-DA connection or what?

Right now an OPC-DA

Ah, right, if I would have read things a little more carefully I would’ve picked up on that. I thought you were using our CLX driver.

In that case: if they don’t provide you with a atomic string tag in addition to breaking out the struct then you’ll have to bring in each of the data elements and then make an expression tag that converts/concatenates all those tag values.

Most unfortunate.

I’m working on a new program in simulation and want to get Ignition programmed before going live. OPC-UA doesn’t support Emulation does it? I tried OPC-UA and it fails out.

Yeah, there’s no support for emulation in the UA server right now. :frowning:

OK. I was able to do a little test on the live PLC Connection and the strings come thru properly via OPC-UA connection. Just something with The OPC-DA.

Custom String types come thru the OPC-UA as well.

I can work with that. thanks for the help!

Cool.

With the DA connection the tags that RSLogix provides are all you can use, and apparently they don’t make an atomic String tag out of the String UDT.

Our CLX driver, on the other hand, does attempt to provide both the UDT itself and an atomic version of the tag that can be used without manually assembling it…

Actually, I believe if you simply bring over the length tag and manually delete the “.LEN” component from the OPC path (and change the type to String), it should work. For some reason RSLinx doesn’t let you browse the actual string value, but you can still get to it.

Regards,

Yes that worked.

Thanks!