RSLogix Firmware 32

Having problems working with ControlLogix platform running firmware 32. Connection appears to be fine.

I can use Quick Client and browse all of the Controller Global tags but when I try to Read or Subscribe any of them all I get is

Status: Bad
Value: null
Quality: [Bad] Bad;unspecified

Ignition 7.9.17

Thanks In Advance

Sounds like you might be using the legacy ControlLogix or CompactLogix and not the newer Logix v21+ driver.

No - I’m using the newer Logix v21+ driver.

Just for kicks I tried ControlLogix Legacy to see what it would report - that’s how I saw that it was Firmware 32.12

Not a straight forward connection though and that may be the problem. They are reworking their infrastructure so right now in my path I’m going from one CompactLogix to another CompactLogix to the final ControlLogix.

The path may be wrong or you may be accessing tags that have External Access set to None.

If you turn loggers for drivers.LogixDriver.Requests.* on to DEBUG level you might see some more error information in the gateway logs.

Not really sure how path could be wrong since when using Quick Client I am browsing tags that are actually on that processor…

Turned on above and get a constant

Error reading 1 array tags; Status=0x01 [connection failure], additional=[0x0318]

Thanks

I think the CIP connection(s) are failing to open somewhere along your your multi-node path. Browsing doesn’t use connected messaging, so it would complete successfully, but reading and writing do use connected messaging.

The spec says 0x0318 means:

LINK ADDRESS TO SELF INVALID
Under some conditions (depends on the device), a link address in the Port Segment which points to the same device (loopback to yourself) is invalid.

What does your connection path look like?

Actual Target ControlLogix is 10.237.3.5
Direct connection to first CompactLogix @ 10.237.1.144
Second CompactLogix @ 10.237.3.144

Host: 10.237.1.44
Connection Path: 1,0,2,10.237.3.144,1,0,2,10.237.3.5,1,0

Correction

Actual Target ControlLogix is 10.237.3.5
Direct connection to first CompactLogix @ 10.237.1.144
Second CompactLogix @ 10.237.3.144

Host: 10.237.1.144
Connection Path: 1,0,2,10.237.3.144,1,0,2,10.237.3.5,1,0

Try this instead: 1,2,10.237.3.144,1,2,10.237.3.5,1,0

I would think this:

2,10.237.3.144,2,10.237.3.5,1,0
2 Likes

PTurmel wins !

Tried yours first Kevin and I was seeing tags on one of the CompactLogix machines - similar to what I was getting on my first 3 or 4 attempts …

Thanks Guys !

1 Like

This happened to be as error message abd it was because my connect to the AB plc did not have the correct cpu slot configured. If error message is happening when trying to write to tag that is in the AB plc. Check that the auDT member is setup as read/write.

Could you please explain this path for newbies? The IPs are self explantory, but what do the single digits represent?

Sure. Connection paths are a sequence of “hops” from the initial connection point, where each hop is a pair of “exit port”, then “address” via that port. Port number 1 is reserved for backplanes, and the accompanying address is the slot number to target. Higher port numbers are for other networks supported by the device. If the network is DeviceNet or ControlNet, the accompanying address is the node number to target. If the network is Ethernet/IP, the accompanying address is the IP address in string format.

Port 2 is the typical exit port for network modules. Modules with two independent network ports usually use Ports 2 & 3 (like a DHRIO module). This is not a requirement, and I’ve seen EDS files that specify odd port numbers. The EDS file must have the port numbers if the vendor wants configuration tools to be able to hop through them (tools like RSLinx).

1 Like

@pturmel Thank you very much.