Running *.jnlp file on Raspberry Pi 3 B+

Hello!

So, at my company we are trying to run an Ignition Project on a Raspberry Pi 3 B+. When we run the command javaws http://<url to our project>.jnlp the project opens IcedTea Web, loads for a little while, and then shows the login screen. However, when I input the credentials and click “Login” it grays out the username and password fields and shows the loading icon, but then the icon goes away and nothing loads. At this point, no matter how long I wait, nothing ever happens.

I am not overly familiar with Ignition so I was wondering if anyone had any idea what might be causing this?

Any ideas, thoughts, or assistance is appreciated!

It’s best to use the native launcher.

I generally use the script below to install the client launcher. Note that this does need a pre-installed Java. You can also use the included Azul-systems Java, in which case you don’t need to launch java -jar, but can use the clientlauncher.sh directly.

wget http://HOSTNAME:8088/main/system/nativelaunch?os=linux -O clientlauncher.tar.gz && tar -xvzf clientlauncher.tar.gz && echo "java -jar clientlauncher/app/native-launcher.jar scope=C project=PROJECTNAME" > .xsessionrc

Edit: the last line adds the client launcher as a startup app, you can also run the command separately.

Use the native client launcher.

7.9.10 Client Launcher has issues with the embedded Java on ARM systems. Use the legacy client launcher referenced in the thread I provided. :slight_smile:

Yeah, I also had issues with the included Java on a 32-bit touchscreen (server was 64-bit). Which is why my script launches the new client launcher, but with a custom java install.

Huh. All my installs are stock Raspian/NOOBS. Did a writeup for others around my shop to be able to set one up.

Raspberry Pi Andon Client Setup.txt (2.7 KB)

2 Likes

Thank you very much for the help! I do have a couple of questions, though. First, in step 1, does it require that the hostname be changed, or can I just leave it as “raspberrypi”? Second, I can’t seem to get past step 6. When I go to http://192.168.140.127:8088/ nothing happens. I am not sure what I am doing wrong.

I tried wget http://HOSTNAME:8088/main/system/nativelaunch?os=linux -O clientlauncher.tar.gz && tar -xvzf clientlauncher.tar.gz && echo "java -jar clientlauncher/app/native-launcher.jar scope=C project=PROJECTNAME" > .xsessionrc in the terminal, and at first it seemed to work. It created the clientlauncher.sh file, and when the file was run, it opened up (what I assume is) the native client. I launched the project, but the same thing happened. I input my credentials and logged in, but it just froze.

I wrote these instructions for use at my facility. The IP address is that of my server. Use the IP or Hostname of yours.

Feel free to modify the instructions to your environment…

Oh… now that you say it, I can’t believe that didn’t occur to me. Thank you very much for the clarification.

1 Like

Well, I went through all of the instructions, but the issue is still the same. I enter my credentials, the input fields and button all gray out, and the nothing happens. I don’t really know what to do.

What version of ignition are you using?

We are currently using version 7.9.8.

Are you on 32-bit Java?

In that case, you should limit your client memory to be under 3 GB (selectable under Project -> Properties -> Client -> Launching in the designer).

I am running 32-bit Java.

In my project, the Client Memory was already set to a maximum of 256MB.

Do you have the client serial support module installed? IIRC, that won’t load in an rPi.

I’m afraid I don’t know what the client serial support module is. How can I tell whether or not it is installed?

Look in your gateway web interface’s configuration section “Modules”.

We do have the client serial support module installed. The version is 4.9.8.

If you are not using it in your projects, uninstall it. If you are using it, you are stuck for the moment. IIRC, IA was changing this module to skip loading on unsupported processors (ARM), but I don’t know if that has been released yet. Hopefully, the underlying library will add support for the rPi…

1 Like