runScript error when used in Expression Binding

I am currently having difficulties with the runScript function within Ignition 8.0 perspective. I have generated a script within “Project Library” called WriteAccess. The script accepts a tagpath input and determines the read/write capability of that tag based on current user. I have been able to successfully run the script using the script console. When i go to transfer this to an expression binding the expression fails to evaluate. the error is “Error_ExpressionEval”. I have tried both the 8.0.6 stable build as well the latest nightly build to determine if it was a software issue.

any help is appreciated. Thanks,

image

If your function has any augments you don’t include the () in the scriptFunction parameter.

Kevin,
thanks for the response. Even with the brackets “()” removed it still fails to evaluate correctly.

Was there ever a solution to this problem. I am running into something similar but with an expression tag after moving from 7.9 to 8.1. My tag is a dataset type expression tag. it runs the following script without error. However it doesn’t return a good dataset it returns a [1Rx1C] ->value[value][0]

runscript(“shared.app.getSetpointDataset(‘B1/Pad’)”).

However when I run the script in a script console it returns a 5x2 dataset as expected.

After I upgraded to ignition 8.1 the runscript functions in expression tags were not functioning properly. I ended up making sure the gateway scripting project was set up, which it was. And then I opened the global project that was created. After that all the expression tags started to work.

Did you ever find a solution to this problem?