RV50 SMS module error send text without country code

Using the RV50x I’m trying to send an SMS without putting the “1” country code for the USA on the front of my 10 digit phone number. For some reason it is almost always rejected with the message

########## Error Invalid Number. Please re-send using a valid 10 digit mobile number or valid short code. THIS IS A TEST

However as soon as I put a 1 on the front it sends with no problems. Except randomly it will accept the 10 digit number without the 1. Can anyone tell me how I can get this device to work in a stable manner without having to put a 1 on the front of my numbers? In the application I’m doing the phone numbers are being taken from Active Directory and I don’t want to have to worry about someone editing the contact number to remove what should be an unnecessary 1 and breaking everything!


I don’t have one with me, but I’m sure there is a selector on the setup pages for the Modem (under Services/SMS) that allows you to set the number format. I recall here in the UK we were able to change the required prefix from +44 to 0

I doubt it’s random. Area codes that are “local” to a device don’t need the “1”. At least for land lines, where the initial number processing isn’t digital. Cell phones generally autocorrect this and pass the whole thing (with country code) digitally no matter how it was entered. It seems your RV50x is too dumb to do this.

For anyone facing similar problems landing here for a solution. The issue, as pturmel pointed out, is that the RV50X isn’t prepared for dialing “non-local” numbers. I have reached out to the manufacturer of the RV450 and they claim to be looking into it for a future firmware release.

In the mean time the only option, if you want to use the built in alarm notification profiles, is to make certain your phone numbers all start with the correct country code (every phone number will need to be 11 digits long). It might be a nice feature if such a setting could be added to Ignition something like “default country code” in the SMS or phone setup area that would automatically add the default country code to any 10 digit number that passes through. Of course, I recognize that this is a very fringe case scenario where I don’t have control over Active Directory AND I’m using AT&T AND it needs to dial non-local numbers.