S7 300 Connection

Hello people,

Im have problems connecting a s7 300 to ignition. i tried a year ago with negative results and decided to use kepserver. but ive noticed there are like 12sec delay between signals from kepserver connected devices and ignition drivers connected devices. but it doesnt serve my purpose now so tried again.

the thing is im connecting the s7 300 devices like any other 1200 device and it just dont want to connect.

Can anyone throw me an advice to connect them or to shorten the kepserver delay?

Show us your connection config… on Ignition Gateway website…
My working connection looks like this:

When you are creating new connection, you must choose the S7_300 driver:

this is my device config in ignition

and this is my kepserver config (which actually works)

its connected via netlink and i ran out of ideas.

Why do you have PDU size in Ignition Siemens driver set to 960?
Have you tried with default 240?

AFAIK, S7-300 supports PDU sizes up to 240, S7-400 up to 480, and S7-1500 up to 960…

Now I see that you have a Netlink adapter…
So then, you must set the Port in Ignition Siemens driver to the port, which is configured on Netlink (default is 1099)…
Or you can look in your Kepware config for the port on the Netlink…

But, you are not using Kepware S7-300 Netlink…??? :confused:
Maybe that’s why you have a 12sec delay in Kepware…?

it seems my previous coworker configured netlink and i dont need to set it on kepware, ive tried with 240 but set same on ignition to validate if that config mattered but it seems it didnt.

1099 port doesnt work either.

to be honest i didnt explore the kepware netlink config but i shouldnt need kepware at all right?

No, you shouldn’t need Kepware…

But I think, that is the time to explore/check the configuration on the Netlink…
AFAIK it has a website…

Here is the manual: