SAML Response - Signature Required [SOLVED]

We are trying to setup SAML IDP to have SSO. When trying the test login, we can get a SAML response that lists our gateway as the destination. But in signature section it says “Signature Required”.

I’m wondering if anyone has experience seeing this and what it may be indicating we need to do.


The SAML response itself contains the text “Signature Required”?

Which IdP are you using? Maybe there is a setting which is requiring Ignition to sign its SAML requests? (Ignition does not currently support this feature)

@jspecht I’m marking this as solved although I am not sure of the cause. What we did was uninstall our SSL certs, test SSO in lab over HTTP and saw that it worked. We then put the same SSL certs back in, made a new IDP with https/8043 and it worked. From Ignition point of view, I changed nothing so I think it may have been on the IDP side, however as I said, the exact issue is not clear.

In anycase, thanks for taking the time to reply.


1 Like