Sample Certificate and Keystore Files for Signing Modules

I'm currently trying to learn how to develop modules, specifically custom perspective components. I've been referencing this project ignition-sdk-examples/perspective-component at master · inductiveautomation/ignition-sdk-examples · GitHub , with example perspective components. I want to see what they look like in the designer, but am stuck on actually building and signing the module. I've tried creating my own certificate and keystore files but have had no luck. Has anyone else successfully created their own files, or know where to find some sample files to use just for testing?

You can just not sign your module for testing purposes; you will just need to run a test gateway with an "allow unsigned modules" flag.

For an example of a "modern" dev workflow for Ignition module development, you can crib from Ignition Extensions, which uses Github Actions to sign modules and has a docker-compose example for local development: GitHub - IgnitionModuleDevelopmentCommunity/ignition-extensions

Two followup questions:

  1. Is there a setting or flag somewhere in the sample perspective component project that will allow me to build the unsigned module?

  2. I'm doing testing on my local machine's gateway, is that fine? And if so, I'm not sure where the "allow unsigned modules" flag is.

1: Set the skipModlSigning parameter in the ignitionModule block in your build.gradle.kts:

2: Gateway Configuration File Reference - Ignition User Manual 8.1 - Ignition Documentation

1 Like

Awesome that all worked out. Current block is now that I cannot install the unsigned module without being in developer mode. My local gateway is the free version, will I be allowed to entered developer mode somehow?

Edit: the exact error is: " This module is not signed and will not load because you are not in developer mode."

Did you see my second link? Gateway Configuration File Reference - Ignition User Manual 8.1 - Ignition Documentation
You need to add a line to your ignition.conf to be allowed to load unsigned modules.

My bad, I'd changed the .conf file but needed to restart my gateway to actually register the change. Thanks a lot for your help!

1 Like