Scan Class Driven Mode

SQL Tags = Database Driving Provider.
Scan Class Mode = Driven
I am using a boolean tag to change polling rate of a scan class but there is no effect when the tag changes from off to on.


Could you post a few more details as to how the scan class is set up? For instance, what are the high/low rates, and what’s the path of the referenced tag?

Try editing the scan class, and then looking at the messages in the console (log into the gateway, then go to System>Console). If the referenced tag couldn’t be found, you should see a warning indicating that. Otherwise, try going to “Levels” and search for “SimpleExecutableScanclass”, and set the level to “all”. Toggle your driving tag value back and forth several times. You should see messages indicating that the execution rate has changed.

Let me know if any of this doesn’t line up. I tried several different scenarios and couldn’t reproduce a problem.


Ok, thanks for calling in, we’ve tracked down the problem and have fixed it for 7.0.8 (coming within hours).


This problem is here again. The “SimpleExecutableScanClass” works but the "“MultiDriverExecutableScanClass” does not.

Hmm, I can’t track down what broke it, but sure enough driven scan classes aren’t working with the external provider. This has been fixed for 7.1.5.