Scheduled transaction group stopped on start of new month

Hi,
i just realized that a scheduled group stopped working yesterday at midnight. Here is the status and the settings:



The plan was to have this group executing always 2 minutes after the full 15 minutes (00:02, 00:17, 00:32…). This worked ok until yesterday and started working again after i disabled and reenabled the group. Ignition version is 7.5.4-beta4.

Hi,

Something about the month switch over must be affecting the time calculation. Did the last execution before that occur correctly at 11:47pm? I’ll go plug this scenario into the unit tests for that scheduler and report back shortly if I find something.

Regards,

Hi,
thanks for your reply. Unfortunately i did not check when the group executed the last time before restarting it, and after that there is no way to find out.

Hi,

It’s ok. I can’t yet explain why it would stop working, but I can see that in a setup like yours, it is incorrectly aligning to midnight for that execution. Perhaps there’s a clue in the fact that the previous execution occurred at about the same time. I’ll keep testing it.

In order to avoid the midnight alignment issue, you should probably change your schedule to be “0:02-23:48”. That will avoid an internal split that occurs when the range spans multiple days.

Regards,

I just discovered that the group stopped executing again, so it’s got nothing to do with the new month. Only thing i can tell from my data is that the last execution happend after 23:45.
I changed the schedule to your recommendation now. Let’s see what happens.

Yes, definitely seems to be something with the cross over at midnight, since the “last exec” and “next exec” are the same on both events. I’ll work on testing this more today and let you know what I find.

Regards,

Hi Colby!
I have the same problem. I have the times settings = 0-24 and the rate is equal to 1 hour, so i want to execute this group every hour…Today i find that the last execution was at Nov 28 23:59:59. I will try different time settings and let you know…Maybe you will find something

Hi,

Thanks for posting, hopefully we can track something down soon.

Regards,

A quick update: This did not happen anymore after changing the schedule ‘0:02-23:48’.

Thanks for the update.

I’ve found that the way the execution is scheduled, if for some reason the delay is calculated to be <=0, the group will never run again. So that definitely seems to be related. As for why that would happen at midnight, I’m not exactly sure… but we can start by making sure to never return a delay of 0ms.

Regards,

I have tried the schedule “0:01-23:59” yesterday and in my case the group again stops to execute…

Hi,

We’ve adjusted a few different aspects of how this system works for the next 7.5.5 beta (should be up on monday). In the mean time, you should probably just run your group in the standard rate mode to prevent the problem.

Regards,

The new beta should be up now, and should hopefully take care of this issue.

Regards,

Thanks! I will test it tonight and let you know…