Screen Index issue

I have a laptop computer with a second monitor attached. I would like to open the Client on the second monitor by default. I have tried using Screen Index of 0, 1 and 2 but the Client always loads to the laptop display. Each time I changed the Screen Index I saved and published the project then restarted it. I have even stopped and started the Gateway to see if that would work. Windows 7 Pro 64 bit. Any ideas?

Are you starting the Client maximised? The Screen Index is only used for full-screen mode.

Here are my Properties settings. What do I need to change?

Those settings look fine, which makes me think the problem is with your laptop. Do you have a normal desktop with twin monitors to try this on?

Okay, I’ll give that a try to see if it is the laptop or not. Need to get it to work on the laptop though because I use it for training and need to display the Client on the second monitor (usually an HDTV or projector).

I’m having the same issue on my desktop computer with two monitors. Client always opens on main monitor no matter what Screen Index I use. I remember a while ago I did have this working on my desktop but I had to edit some Ignition configuration file to change the monitor index. I just can’t remember what the file was and can’t seem to locate where I got that information from. Desktop is Windows 7 Pro 64-bit.