Screen Resolution questions

#1

I am not sure if the locking feature, not sure of this is what it is called, but it basically locks items to a screen so as the screen changes the position remains constant. But anyway I am not sure if this feature would do what I am thinking.

We recently purchased a large HP monitor that has a very high resolution capability. Somthing like 1900 x 1200 or something close to this. Anyway if I design a screen with this resolution and then I try to run the project on a monitor that does not have this capability it does not show all my items I put on that screen. And it does not have a scroll bar to scroll down to see the rest of the screen. Is there a setting I am missing so that it will run on any resolution monitor and if the resolution of the designed screen exceeds the resolution of the monitor in question it will provide a scroll bar or something that will allow you to see the entire project screen?

1 Like

#2

I would recommend reading about layout in the FactoryPMI documentation and playing with it. There are several posts that get into it as well including this example. I would also consider downloading the skeleton project from our FactoryPMI goodies. Window properties also might come into play.

To address your question, I’m not sure why you wouldn’t get scrollbars. Perhaps relative mode is shrinking your components down. Starting from a higher resolution shouldn’t inherently make any difference. We might need to check out a backup of your window/project or check out your computer over a remote connection. I have a feeling that this problem might work itself out after you figure out layout and windows.

0 Likes

#3

You aren’t getting scrollbars because your main window is set to maximize. It will maximize to whatever size the application frame is. If you want scrollbars to appear on smaller monitors, set the minimum size property of your project to be something slightly smaller than 1900x1200. To set the minimum size, select your project (either in the project tree or just click on the background of the design area) and edit the property in the property table.

You should also look into layout - if you want your objects to shrink and grow based on the screen resolution, you should use relative layout rather than anchored layout.

Hope this helps,

0 Likes

#4

So lets say I design a screen in the designer and when I first make up the screen I set the resolution to this high number of 1900 x 1200. I do this so when I am designing the screen I can fit the required parts on the screen. If I am understanding what you are saying if I take the check box away from the Maximize setting and I run the application on a PC with a smaller resolution monitor I will see the screen with scroll bars because it was designed at a higher resolution. Is this correct?

I am going to try this. Because I do know that in the pane which sets up the window information the base resolution I think is set at 800 x 600. I will let you know how I make out.

[quote=“Carl.Gould”]You aren’t getting scrollbars because your main window is set to maximize. It will maximize to whatever size the application frame is. If you want scrollbars to appear on smaller monitors, set the minimum size property of your project to be something slightly smaller than 1900x1200. To set the minimum size, select your project (either in the project tree or just click on the background of the design area) and edit the property in the property table.

You should also look into layout - if you want your objects to shrink and grow based on the screen resolution, you should use relative layout rather than anchored layout.

Hope this helps,[/quote]

0 Likes

#5

Thank you. You were absolutely correct. I did have the maximize on for those screen in question. Once I turned the maximize off it allowed the scroll bars to show up and I was able to use them to view the entire page.

8)

[quote=“Carl.Gould”]You aren’t getting scrollbars because your main window is set to maximize. It will maximize to whatever size the application frame is. If you want scrollbars to appear on smaller monitors, set the minimum size property of your project to be something slightly smaller than 1900x1200. To set the minimum size, select your project (either in the project tree or just click on the background of the design area) and edit the property in the property table.

You should also look into layout - if you want your objects to shrink and grow based on the screen resolution, you should use relative layout rather than anchored layout.

Hope this helps,[/quote]

0 Likes

#6

Is this in Vision or Perspective? I am facing the same issue with components that have an angle, are either changing position, or the scroll bar appears over them.

I have tried Flex container adding the view as an embedded view on the first place. Then I simply tried to change the entire view background set to percent to hopefully adjust when integrating the screen on a smaller resolution but I seem to be getting the same issues. Any ideas?

0 Likes

#7

Hi Alex,

You just posted to a 12 year old thread. :slight_smile:

However, take a look here:

0 Likes

#8

Thank you for the link. This doesn’t seem to have fixed the error.

I basically have a view made in 1920x1080 and I need to display it on an HMI of 1024x768 resolution. Up to date components keep changing position(mostly the ones tht have an angle set, either the scroll bar appears over them. Ive tried using a Flex container but it doesn’t seem to work. any ideas?

0 Likes