Script datasource in reporting module only returns first row

	newList = []
	rowData = []
	for i in range(4):
		newList.append(i)
		rowData.append([i])
	
	header = ['Numbers']
	ds = system.dataset.toDataSet(header,rowData)
	
	data['testKey'] = newList

We are building a number of reports with script data source as we are getting data from Sepasoft MES modules. Currently having issues getting any script data source to work correctly. In the description of the updateData function it says the data argument takes values that can be sequences, scalar values or datasets, but the report preview only seems to display the first line.

We have tried with both a list and a dataset and neither result seems to work.
It seems odd that in each case the value is printed four times, so it is obviously aware of the length of the list/dataset.

Perhaps there’s something we’re doing wrong in the design section?

image


Use the dataset. In the table design, for the header, put static text. In the details section, use a field with key @Numbers@. Do not include @testKey@ there.

2 Likes

Make sure that the table itself has it’s data key set to @testKey@, as well.

Thank you, this worked