Script Resource Locked

I have a couple of Global Scripts that I cannot delete or edit and when I try to open them they display a ‘Script Resource Locked’ message as shown here:

This came about when I copied the scripts from a project folder to a global folder.
There are no other Clients or Designers running.
I have tried restarting the Gateway PC multiple times, backing up and restoring the project and updating Java. Nothing will let me delete these files!
I am running Ignition 7.7.4 and Java 1.8.0_45.
When the error first occurred I was using Java version 1.8.0_25.

Does anybody know how I can delete these files?

Any ideas on this one? It’s still a problem.

Can you look through the sessions list in the gateway webpage under the status tab and see if there are any designers open that you don’t know about that have these resources locked?

I checked this at the start and there are none.
I’ve tried closing all clients and all designers and then opening a new designer on a different PC and it still had the same problem. I just cannot edit or delete these files!

Just for info, this has now been sorted by Sam from Ignition Support.
He had to delete the files from the Internal Ignition Database.

I have this same problem in my gateway. I have tried even rebooting the server but there is no solution. Can you help me please?


I continue with the problem. I’m not able to find out the solution. Please, could anyone help me?


OP solved his problem by calling IA support. That’s what I would recommend.

Have just come across this due to similar issue.
Are support monitoring this?
At moment, my workaround is to edit the script where it was created, but that not always ideal.
There must be a fix…?

Hi @scott2, after contacting tech support, they admitted it was a bug. In my case this was almost 3 years ago for Ignition 7.7.4. I am not aware if they fixed it in later versions.

Anyway, open a ticket because this OEM feature is very specific and I don’t believe many people use it apart from us.
Your workaround is the only solution I had too.