Scripting Functions of Signature Pad doesn't work any in 8.1.4 any more

Both .clearSignature() and .submitSignature() Scripting Functions of the Signature Pad doesn’t work any more in 8.1.4. It seems a regression.

I just tested both of the function in 8.1.4 and found that they worked as expected. Can you provide some insight into why you don’t think they’re working?

Hi
I use this example from forum. But it doesn’t work at it shown.
SignaturePad_20200304135553.zip (32.8 KB)
s

Do you see any errors in the Gateway logs? My test attempt did not rely on the reference chain (parent.parent.child.child) which your example does, and mine worked fine.

Update: it’s not the signature pad, it’s the spaces in the component names.

1 Like

You are right about the spaces now it is working. But shouldn’t it be working with name with spaces in it? It is very normal and common to use space in component name
If yes, is it bug?

It should work, yes (and so this is a bug), but I haven’t been able to verify it is a regression just yet.

1 Like

Could you send me this View? While attempting to replicate this in older environments I found that my original attempt had not saved a script change and that was resulting in my being able to replicate it. Once I repaired my script in 8.1.4 the component began working correctly.

SignaturePad_20200304135553.zip (32.8 KB)

This appears to only be failing in the Designer. When I open the supplied view in a session the script behaves as expected. The request being made relies on a constructed request to the component which references an ID for the component which is constructed using the page+view+component path. Since the Designer has no PAGE, the ID is incorrect, and the clear/submit events will not occur. This isn’t a bug, because the Designer should not be used for front-end execution logic.

1 Like