Separate Alarms Issue

I am using Ignition version 8.1.1 and I am using Vision.
I am in the process of replacing all of the SCADA for a plant. The first part of this went well. It was replace the control room SCADA. The second part is giving issues. I have alarms that need to show up in the control room only and I have alarms that need to show up on HMIs on the floor only. I have an Alarm Status Table on a docked window for the control room and I have Alarm Status Tables on the bottom of each screen for the HMIs. I have set the Display Path Filter on the control room Alarm Status Table to show XS_0281_01_C0 which is the PLC for things the control room controls. i set the Display Path Filter for the HMIs to A1368A which is the PLC for the two HMIs to control.
With everything running and all alarm evals enabled none of the alarms show up anywhere. When I disable the alarm evals for the HMI screens, the control room alarms from PLC XS_0281_01_C0 show up correctly. But with the evals for the A1368A disabled, obviously they don’t show up anywhere.
I tried setting the Display Path within the alarm settings on some from each and that doesn’t seem to help. I can get all the alarms to show up for the control room but that doesn’t help the HMI operators and confuses the control room operators since they aren’t used to seeing the HMI alarms.
What do I need to do to get the HMI alarms to show up on the HMIs and the control room alarms to show up in the control room?

Are you filtering on the source path? If not you should
Are you including wildcards? E.g. *XS_0281_01_C0*

TBH, I’m not sure how your tags are structured and how you would be filtering alarms by plc name?

1 Like

I have nothing for the Source Filter. I will try changing from Display Path Filter to Source Filter and see if that works.

I changed to Source Filter and all the alarms stopped showing up.

Sorry, forgot to use preformatted around the filter. It killed my asterisks, edited above.
Still not sure how adding the device name though to a filter will get you the alarms that you need, unless your tags are all within groups with the name of your devices?

You will likely need to define a custom parameter on all of your alarms which assigns them to the area to which they belong, then you can use the alarm status table’s filterAlarm extension function to filter by that custom proepry value

That seems to have fixed the issue. Thank you.

No worries. Ps, the reason to use source over display path is that the source will never change, it will always contain the tagpath and some other stuff. The display path on the other hand is user definable but defaults to the source. But the point is that it can be changed to something completely different which your current filter may not work on.

1 Like