Sepasoft Web Services item not showing up in the Project Browser?

Ignition v8.1.7
WebServices v 3.81.1

image

I don’t know if they hang out here regularly, might want to contact their support.

Are you opening the MESGateway project?

image

I did notice this out of the corner of my eye, the thought never crossed my mind to check what it was for though… If that’s where we have to do Web services though, that’s a bit dodgy. What if we have more than 1 independent project in the gateway that we want to keep together?

Edit:
Yep, web services are shown within the MESGateway project. Well that’s a bit silly…

image

I also found this:
https://help.sepasoft.com/docs/display/MHD/Ignition+8+Readiness

I’ve changed the Web Services module to use my main project instead

Edit edit: I don’t know why I’m using this module… it’s easier to not use it, and also the Designer keeps jumping back to the Web Services restful consumer randomly when I’m working elsewhere e.g. in the scripting module

Ignition Web Services Dodgy

Love the idea of the this module, tried it out a few times, but never found the value for the money over just writing some wrapper functions/classes around httpClient. I have not tried it recently, but it choked on complex SOAP endpoints. The only big benefit they have is NTLM auth support for WebServices if you need that sort of thing.

Yeah, seems like a bit of a waste of money for what we’re supposed to be using it for. We have an endpoint and a key to use, no authentication at all. If using auth and/or hosting an endpoint then it would make sense, but seems like more work for me now.