Serial ASCII troubleshooting


I’m having some trouble talking to an RFID system talking ASCII serial via. The RFID talks rs422 and I have a rs422 to rs232 converter connected to a rs232 port on my PC (COM2).

At the moment I can talk to the RFID system with other terminal programs such as S2_util (Texas instruments program and Multiway (Omron program), with no problems at all.

I am using the serial modules (have both client and gateway installed).
Here is my setup for serial that works in multiway -

  • 9600 baud
  • 8 data bits
  • No Handshaking
  • No Parity
  • 1 Stop bit

Here are some snips of my setups

[attachment=1]Multiway setup.JPG[/attachment]
In the Multiway the left handside is what I should be receiving ‘LI’

in Ignition I get
[attachment=2]Ignition Script console.JPG[/attachment]

and when I turn handshaking off on the multiway I get a similar thing
[attachment=0]multiway handshaking on.JPG[/attachment]

Can someone maybe spot something I am missing?

Thanks, Cam

Try hardwareFlowControl=False.

Still no luck. Have changed and tried most setups without any change in the output.
Has anyone got any examples of using the serial module talking to anything?

Have found a solution.
Found that my RTS and CTS were not wired correctly (not crossed over) in my cable between the PC and serial converter.
Looks like setting Ignition HANDSHAKE_NONE doesn’t turn off CTS and RTS in the background(software), where Multiway stopped handshaking all together when set to OFF.

Could this handshaking (not checking RTS/CTS) be something to look into for ignition?