Session Custom Property: Not initialized on start up?

I have an inherited perspective view that opens up as the home page for a project. The view contains a toggle switch which has a bi-directional binding to the custom session property (default value is false).

I have the custom session property setup in both the parent and child project. When the session opens, the toggle button has an error overlay until I select it. While the error overlay is present, the barcode scanner component does not work.

Any ideas why the custom property is not using the initial false value, and why does it have an error overlay?


is your session custom property marked as persistent?

I didn’t realize that was an option until you mentioned it, but yes it is marked as persistent.

If you hover over it does it tell you what the actual error is?

In the designer, it doesn’t have the overlay. In the session, I hover over the component but no error message appears.

EDIT: you can’t see the error symbol unless I maximize the browser.

  1. Bad_NotFound: root/ToggleSwitch.selected

how does the session custom property look?

The only way i can make that error popup is if i delete the session custom property :frowning:

Interesting, the custom property in the child project disappeared. I added it back and it fixed it. I know that I had it in there.

I do run into the perspective designer getting into bad states sometimes. Earlier, I would add a custom property and after I put in a value, the screen would flash and the property would disappear.

Either way, a designer restart and adding the property back to the child project fixed it. I should’ve caught that, but appreciate the help!

Yeah, i’ve seen some weirdness with perspective where I have to close my window / designer.

Glad you got it working though! :slight_smile:

1 Like