Setting column width in table

This seems like it should be simple but for some reason I can’t figure it out. I have a table with the data bound to a select query. When I open the column attributes data I see a width setting but I can’t edit it. When I open the table customizer I don’t see the width setting anywhere.

In order to set the column widths of a table do the following:

  1. Go into preview mode in the designer
  2. Set the column widths by resizing columns
  3. Leave preview mode
  4. Go into Table customizer by right clicking on the table
  5. Press OK to save

Now the widths are saved. Next time you open the window they will be the same.

OK. That’s a little bit cumbersome but it works.

Yeah, its weird, I’ll admit. We’re trying to figure out a better way.

We never found saving the table widths to be reliable. We’ve ended up setting the table widths in code every time a window is opened.

Thanks for the tip, Carl. The trick is opening the customizer after resizing in preview mode. It might be helpful to add a note to the manual to that effect.

The manual just says:

[color=#0000FF]Changing the Column Widths
To change a table’s column’s widths, simply switch into preview mode and use your mouse to resize
the columns, and then switch back to design mode. Simple![/color]

If you don’t open the table customizer and click OK, it looks like your new column widths were accepted in designer, but they don’t “stick” in the client application.

Yeah, it’s goofy. This will be changed for 7.3

I noticed that this didn’t get fixed in 7.3. Am I missing something?

No, you’re not. It didn’t make the cut, sorry.