Shortcut Creation Failed

Hi,

I’m trying to create a shortcut to a Ignition Perspective project via Perspective Workstation but I always get this error. Am I missing something obvious?

Thanks

Also, any idea what is spawning on these other gateways? Safe to say I’ve set something up incorrectly inside the gateway but I can’t figure it out.

Can you check the designer launcher log? Should be at %LOCALUSER%\.ignition\clientlauncher-data\designerlauncher.log - see if there’s any entry being logged when you try to create the shortcut. At a basic guess, it’s probably something with filesystem permissions.

It’s probably all one gateway, but reporting different IP addresses on your different NICs - are you on a development machine that hosts many VMs, Docker containers, etc?

1 Like

Hey Paul,

Not much detail in the log, looks like it might be an issue with the icon it’s trying to use to create the shortcut? I can’t see anywhere to alter this though.
‘INFO [ShortcutUtil ] [2021/07/26 08:51:31]: image must be in ‘.ico’ format for shortcut use. Using default image.
ERROR [ShortcutUtil ] [2021/07/26 08:51:32]: unable to create shortcut’

I’m running Workstation as an administrator and I’ve tried on different users without any success. I’ve currently just setup a shortcut to boot the client into a chrome browser although I think it would ideally be better to be running via the Perspective software?

Regarding the second point, it’s a brand new stand-alone PC for running Ignition with nothing else installed except for Ignition but I think it’s just related to my worksite domain and its DHCP server updating my workstation address. Not a big issue, just wanted to make sure I didn’t have something configured incorrectly.

Thanks for your help

Wow, I gave helpful suggestions for the designer and totally ignored that you’re trying to use Workstation. I think the basic principle is the same - there should be a workstation log file. However, to get much useful out of it, it looks like you’ll have to set the logging level. For the designer launcher, it’s an entry in the designer-launcher.json file:
image

Try setting the corresponding entry in the workstation config file to TRACE and creating the shortcut again; there might be more useful information logged.

What version of Workstation are you using? This sounds like a bug that might have been fixed at some point since 8.1.1 if memory serves.

Hi guys,

Set the logging to Trace but it didn’t seem to add any extra detail to this error.

DEBUG [ShortcutUtil ] [2021/07/27 09:45:28]: Making a windows desktop shortcut
TRACE [ShortcutUtil ] [2021/07/27 09:45:28]: imageName:
INFO [ShortcutUtil ] [2021/07/27 09:45:28]: image must be in ‘.ico’ format for shortcut use. Using default image.
TRACE [MulticastReceiverService ] [2021/07/27 09:45:29]: SocketThread received valid response. Gateway was previously found.
TRACE [WorkstationLauncher ] [2021/07/27 09:45:30]: Multicast data update finished
ERROR [ShortcutUtil ] [2021/07/27 09:45:30]: unable to create shortcut

@jcoffman I was using 8.1.1 but I have since updated to 8.1.7, issue still remains.

@jcoffman, realise you might probably meant workstation rather than the Gateway - I was thrown off by Workstation saying it was version 1.1.1 though. I’m trying to upgrade Workstation now but get this error when I try to do it via the in-app prompts.

image

image

I’ve tried upgrading just by re-downloading Perspective Workstation from the gateway but it didn’t upgrade me to 1.1.7 for some reason? Is there another way to complete this upgrade?

Okay, so I uninstalled Workstation, downloaded again from the Gateway and reinstalled which updated to 1.1.7. Shortcut creation is working without issue now!

Seems like it was just a bug related to v1.1.1? Anyway, thanks for the help, much appreciated

1 Like

yeah you hit two bugs which have since been fixed (shortcuts and the download link). Glad you got it working!

1 Like