Siemens Data Block addressing not working

Hello, I got a 1500 Siemens PLC accesible through Ignition but I can’t acces DB824. I tried to access the standard controller tags and no problem but when I try to go to the DB it always give me a “Bad” connection. Already checked that it is a non-optimized blocked and it is accesible through OPC. I use address [MC1]DB824,X106.1.

The syntax seems correct for accessing the bit value.

Is this the only DB you cannot connect or is it an issue with all DBs?
Does that DB and bit DB824.DBX106.1 exist on the PLC?

So unfortunately all the other DBs on that project are optimized so I’m not sure how to access those. But I tried with a different project and I was able to create the tag correctly. I recently changed the DBs to non-optimized after I had already created the connection on Ignition OPC, I’m not sure if that affects it. And yes the bit does exist on the PLC unless I’m doing something wrong, see image.

If that DB is actually downloaded into the PLC you should be able to get the bit value.
I guess you tried to see if you can get any other data from that PLC.
Have you tried to read a merker or an I/O bit i.e.?.
[MC1]MX0.0 should give you the value of M0.0

Yes, already tried that I was able to read normal controller tags like your example but the DB keeps giving me problems. I also tried erasing the device on the OPC browser and add it again and nothing.

Are you trying to read other data from the same DB other than this bit?
I think in the past I was having a bad reading of a correctly declared variable because I was trying to read another part of the DB that wasn’t existing from another point of my application.

If not, in your case, I would create another new no-optimised DB in that PLC, with a single word/bit and would try to read it instead.

I found the issue, I had the wrong IP when setting up the PLC on Ignition Gateway. The problem it was an IP of a different PLC so I was able to reach the memory bits but not the DBs. Now I feel dumb haha.