Siemens S7-1500 tags stopped working - config error

I have a project that’s connected to a Siemens S7-1500 PLC.
All was fine until I went on to make some changes and noticed that certain tags were showing “config error”. Plenty of other tags are reading fine. I’m pretty confident that everything used to work ok.
I’ve attached a screengrab that shows some of the issues, in particular I can’t read any Booleans from DB60. I’ve disabled and re-enabled the PLC connection but that doesn’t seem to have made any difference.

Ignition version 7,6,7

Look at the last post… :slight_smile:

Sometimes that is the only thing that helps…

Thank you for the reply. The thread makes interesting reading.
Ideally though I don’t really want to restart the gateway if I can help it.
Also, my tags are saying “CONFIG ERROR”, not “BAD QUALITY”.

As an example [CoolTower]DB60,X0.0 does not work but [CoolTower]DB90,X0.0 does!

I tried just restarting the Siemens Driver Module. No difference.

I tried deleting the device, restarting the module, recreating the device. No difference.

Also when recreating (or enabling) the device it can take a minute or more to actually go to state Connected.

I then tried creating a 2nd device (different name) but pointing to the same PLC. This connected within seconds.
I then tried one of the troublesome addresses. It worked.

So maybe somewhere within the system there is some bad/corrupt info relating to the CoolTower device name?

If I create a 2nd device CoolTowers instead of CoolTower then I need to go and update the OPC path for every tag for that PLC.

I guess I could export the whole tag database, do a find/replace then reimport.

But I also wondered if there was a way to do it directly on Ignition’s internal database?
In the Raw Settings bit under console?
Remember I’m on version 7.6.

Any thoughts? Or do I need to go directly to support for this?

You said, you delete the device, restart driver module, recreate the device…
But the tags were still created (in the internal db, or … somewhere)…

In my experience, it’s the best to do in this way:

  • export tags into xml
  • delete all tags
  • delete the device
  • stop gateway
  • start gateway
  • recreate device
  • import tags from xml

Yes my tags have always still been created (as it’s not easy to just isolate the ones just for this PLC).

I questioned whether some reference to the device itself still existed somewhere, in that if I delete it and recreate it with the same
name then the problem persists, but if I create a new identical device with a different name then at first glance it appears to work.

An update, if anyone’s interested.
I’ve managed to largely resolve this - the issue was that I’d been given some incorrect addresses for some of the DB60 tags.
Just one tag with a bad address was effectively wiping out the whole “request” for the DB60 block so all my DB60 tags were showing config error.

1 Like

Ha… I would never thought of this…
Mainly because I’m the person who gives the PLC addresses to me… :laughing:

Same issue - Incorrect addressing on tag seemed to knock out any new tags from being detected. Exported all tags from the PLC device in groups and imported them in groups until I found one causing issues. Redid those tags from scratch and had no issues since.