Site can’t provide a secure connection

Cannot access ignition gateway. Can somebody provide a solution?

Cannot access the gateway totally in Chrome. However, if I try to open it in Microsoft edge I can still access gateway even though the connection isn’t secure.

What port are you trying to access it at, and are you using http or https?

https

Try http instead, by default Chrome won’t allow HTTPS access to localhost unless the certificate is valid.

I’m assuming you have HTTPS enabled and a certificate installed - is that correct?

As soon as I try with http, chrome automatically changes it to https on its own.

Yes, I have the Always Use HTTPS toggle ON in Settings. Not sure how to check for the certificate though. Using ignition since past 6 months, and until yesterday gateway was running just fine in chrome. It happened today out of nowhere!

I’ve encountered this before. If you inadvertently visit a site with https, Chrome tries to refuse to back down to http “to help you”. :slight_smile:

Here is a quick workaround–use http://something-that-youd-like.vcap.me:8088. VMware still runs a localhost wildcard DNS resolver that resolves <anything>.vcap.me to 127.0.0.1 (localhost). I typically use this when I’m running multiple gateways locally (via containers) on different ports to keep from having to constantly log back in when switching between (and helps avoid needing to use incognito mode which can help achieve a similar goal).

EDIT: for folks interested in a more advanced service (which you can also run yourself if desired), check out https://sslip.io.

3 Likes

Yeah understood what you are trying to say here. Thanks that did work for me!