SMTP configuration


I am having a problem regarding the usage of an SNTP server with Ignition.
We opended a email account on our mail provider, with our company main domain, "domainA", and we connected Ignition using the credential from that account. It might be worth noting that the server running Ignition is behind another domain name, "domainB".

Now, whenever Ignition try to send mails, through a notification pipeline or with the test mail function, the message only goes through when it is send to a domainA adress, or to a service by our server provider that we use to send SMS (basically, we send a mail to that service and it sends an SMS to the number specified in the mail object). Every other mail we tried, we have an error "Relay Access denied".

Sounds like a configuration issue on the SMTP server more than an Ignition issue.

1 Like

Well that's what I thought, but when we connect to the very same email account through a regular client, we can send email just fine.

Your screenshot shows Gmail is special.

Maybe, but it isn't the problem here

Relay access denied is a common error in mailservers when authentication fails, or perhaps, isn't even attempted. Are you sending through an intermediate mail server? Can you see its logs?

You don't show the email profile settings. You are also obscuring domain names that might be relevant. You might want to have IA support look over your shoulder.

I don't think I can see the logs for the SMTP server. Whenever a domain name is obscured, it's my company private domain. It is a domain hosted by OVH (french hosting company). They host both our ignition VM, and our SMTP server (which are on different domains). Here is the SMTP config :

Many services won't accept authentication in plaintext connections (port 25). Try turning on TLS or STARTTLS.

I bet your working email client is submitting on port 465 or 587, with encryption.

1 Like

Oh, I got it !
I turned on TLS and STARTTLS, change it to port 465, and change the hostname address to another I found that supports the SSL configuration. I did not think of looking this way because since it connected and I could send some mail, I thought the configuration was correct.
Thank you very much for pointing me in the right direction !