SMTP good but Alarm Pipeline not working

Not sure if this has been touched on already, but I’m having issues with testing my alarm pipeline…When I test my SMTP Server via the Ignition Gateway the email sends, but when I try to test my alarm pipeline/notification profile I get nothing. I’ve tried using my On-Call Roster set up and even my email as an expression for the ‘contacts’ with no luck. Here is a picture of my alarm pipeline for reference. Thanks

Have you tried using Test Mode in the Notification Block properties? The Test Mode property, once enabled to true, will send a message to your gateway logs of how your email would have been sent out if the alarm was triggered. This will help you determine further if the error is in your pipeline or your SMTP profile.

1 Like

Madison, have you found the problem with this? I am having the same issue. Alarms were working for several months, but recently stopped sending. Testing the alarm profile does send a test email, but we can not send out any alarm emails.

I’m having a similar issue, Alarms and Reports were all working fine for a long time using the Google smtp. Now it seems Google no longer allows connection into their server without a 2 factor authentication as of May 30, 2022.


Not sure if already tried but we can generate a 16-character password and use that as a password in the SMTP profile settings.

  1. Turn on 2-Step Verification in your google account. This step is required as Google only allows generating passwords for apps on accounts that have 2-Step Verification enabled.
  2. Go to generate the app’s password (Sign in - Google Accounts) and generate a password for your app.
  3. Simply use your email username ( and the password generated in step 2.

That fixed my issue, Thank You very much

I used two step authentication via Google SMTP server suggested by ganhali4 and then the test mode suggested by Mikhail_Simin in the notification block properties to confirm emails sending again. Thank y’all!