SMTP setting without password

I try to add an SMTP profile (no password) in the email settings.
If I turned the pipeline mode to TEST MODE. The messages shows
[hostname=,port=25] THIS PROFILE IS RUNNING IN TEST MODE. The following email WOULD have been sent So seems the configuration is okay.

While I test the pipeline and notification profile, there is below error message.
Do you have any idea how to solve it
Thanks in advance :slight_smile:

javax.mail.AuthenticationFailedException: failed to connect, no password specified?
at javax.mail.Service.connect(
at javax.mail.Service.connect(
at javax.mail.Service.connect(
at javax.mail.Transport.send0(
at javax.mail.Transport.send(
at java.util.concurrent.ThreadPoolExecutor.runWorker(
at java.util.concurrent.ThreadPoolExecutor$

No, running in test mode implies nothing about your SMTP configuration being correct. No contact with the SMTP server is attempted.

What version of Ignition are you using? I think some versions had an issue with trying to use no password but it may also turn out that you actually need one.

Thanks for the fast reply!
The version I’m using is 7.9.2. If it’s the version which faceing this problem?

Seems it was a much older version than 7.9.

This particular error message means that a connection to your configured SMTP server was not able to be made, and that it noticed you did not specify a password and is suggesting that might be the issue.

Thank you for the reply!
I just noticed that it’s because I wrongly set the username which leads this message.
Now seems no error from log.
Last question, is there any way that I could find(or configure) the log like" the notification has been sent to the receivers". Cuz I can not involve myself to the receivers list.
But for debug purpose I would like to see the positive log (like the one you have in the TEST MODE)

There’s nothing built in to do this, but you could set up auditing and check the audit log or insert a Script Block somewhere in the pipeline with your own logging statement in it.

1 Like

I have activated the Audit for logging.
Now the problem I met is

  1. I tested the pipeline and notification profile from gateway -> User A could receive it -> ok
  2. I try to active the alarm
    from the Stato/Diagbostics/Log -> email notification :no error logged
    Infomation (pipeline) : Alarm pipeline started.
    from Audit table -> email has been sent to User A with STATUS_CODE=192
    but from the point 2, User A haven’t received any email.

If you have any idea where I might miss to check

Hello @Yeyu2509 and @Kevin.Herron ,

I just ran into a similar issue today on my 7.9.12 gateway.
Step 1: I define an SMTP profile for sending email with a user account without password
_ The profile test with the gateway HMI (config> Email settings> test) works correctly OK
_ If I define a password, there is an error ‘No authentication mechanisms supported by both server and client’ NOK

Step 2: I associate the previous SMTP profile with the alarm notification.
_ The pipeline returns an empty password error and there is no send
_ If I define a password, there is an error ‘No authentication mechanisms supported by both server and client’ NOK

It seems that the ‘email sending test’ function works differently than the sending of email by the alarm notification module.

sorry to revive an old thread, but I couldnt find the answer so sharing here.

I had the same problem occuring where I had a working SMTP profile (no password) setup that I could send emails with, but it wouldnt work with the notification block in an alarm pipeline.

javax.mail.AuthenticationFailedException: failed to connect, no password specified?

I just put in a random password into the email settings of the profile and saved it, and that made it work.

A workaround is to use a script with the function ’’( - Ignition User Manual 8.1 - Ignition Documentation)’

true, but you lose some of the nice things about the notification block, like consolidating alarms

At the time, I opened a support ticket concerning this point … ‘to be continue’

Hello @r.lebohec
Seems you have met the error similar with the one I had before. In this case, might be your smtp server also does not require any auth? and you could try to empty both username and password section in SMTP configuration and then test alarming part?
For me, it works! Hope this info could be helpful. :slight_smile: