[SOLVED] Native launcher not starting under Zulu built in JRE linux

Installing native client (linux 64bit arch) on a small format PC (AMD Ryzen 3 4300U/Video baked in AMD Renoir)

Ignition 7.9.18 ( b2021062913)

Cannot start client on X (xorg version 1.20.13-2) if I use the ignition supplied Zulu JRE. (9.0.7.2+1)
Works fine if I use a generic system Java (eg 8 JDK. 1.8.0-292-b10)

runtime/bin/java -jar app/native-launcher.jar

Yields log

INFO [ClientLauncher ] [11:21:35,154]: Using /home/ignition/.ignition/clientlauncher-data/clientlauncher.log to store logging info. Check there for all future logging events.
INFO [ClientLauncher ] [11:21:35,180]: Shortcut doesn’t contain useBundledJre arg, defaulting to true
Problem invoking method public void com.inductiveautomation.ignition.client.nativelaunch.ui.component.ProgressBar.setOpacity(float) in object com.inductiveautomation.ignition.client.nativelaunch.ui.component.ProgressBar[,50,250,249x6,disabled,alignmentX=0.0,alignmentY=0.0,border=,flags=16777216,maximumSize=,minimumSize=,preferredSize=] in setValuejava.lang.reflect.InvocationTargetException

On my linux laptop it works fine (KDE/Arch also Xorg:1.20.13-2 i7-3740QM AMDGPU driver on AMD Radeon HD 7970M )

Problem persists if I switch Xorg to use vesa driver rather than AMDGPU.

At this point I’m assuming it is related to the CPU/Video card.

If others experience similar the easiest workaround is simply to remove/rename the runtime directory. int the clientlauncher directory.

Just to point out.
The Native Client Launcher does not need Zulu. I think

The Azul Zulu build is the bundled JRE from ignition included in the client launcher.

As indicated using a native java worked around it.

I have managed to get it going…Since this is a kiosk application I ended up going totally minimalist and dropped using any display manager and then it started working. No idea what resolved it. Its the first time I’ve ever had any such issues with the bundled JRE.