Sparkline with Tag Historian binding showing in designer but not in session

Like the title says, I’m trying to get a sparkline in a Perspective view. The line is showing in the designer but not in a session (Chrome or Firefox). I tried closing the view, reopening it, closing the designer, and other things to try to make the spark disappear in the designer, but it remains. I also tried to refresh my session, clear cache, reboot the server, and I couldn’t get the spark to show up. What I do know is that if I disable the Tag History binding and keep the 50 points in the dataset, I’ll get a line in the designer AND in the session.

I have a Tag History binding type defined on the points dataset of the sparkline.

As you can see, what is different (v8.1.14) is that I’m using an expression for the tag definition. Here is the key that’s displayed in the snip:


I set up this structure according to the docs here.

Any ideas why this is happening?

The setup looks accurate. I just replicated it and it works as expected in a Session (albeit on version 8.1.13).

I would recommend checking the “Enabled” box on the Binding itself.

I would also recommend scrutinizing the “path” property since it has a binding. The binding on it perhaps isn’t returning what you expect in the Session. You can add a label component and bind the label text to that property - to ensure it is a valid tag path in the Session.

The problem was that I wasn’t specifying the tag provider (i.e. [default]) in the tag path. I should’ve caught this earlier. Thanks @kvane!