Sparkplug and historyEnabled property. (node-red)

Hi :face_with_monocle:

I am having troubles getting history enabled through the MQTT engine. I actually got it to work a while ago, and im not sure what i did to the code in the meanwhile.

I am currently sending the folloing metrics in the NBIRTH.
All the below properties are initialized in the MQTT engine, with the exception of historyProvider, and
historyEnabled. Any idea why? :confused:

var metrics= [
            "name" : Equipment08/Temperature/value",
            "value" : 0,
            "type" : "float",
            "properties" : {
                   "engUnit" : {
                        "value" : "mm",
                        "type" : "string"
                    "engHigh" : {
                        "value" : 1337,
                        "type" : "double"
                    "engLow" : {
                        "value" : 13,
                        "type" : "double"
                    "historyProvider" : {
                        "value" :"Dobot_DBUtility",
                        "type" :"string"
                    "historyEnabled" : {
                        "value" :true,
                        "type" : "Boolean"

A previous version of the metric had the “missing” properties defined something like this.

"historyProvider" : {
                        "propertyValue" :"Dobot_DBUtility",
                        "type" :"string"

Attached is a screenshot of the tag browser just after birth



Seems like having MQTT Engine save tag history would be a popular feature with or without SparkplugB. I am trying to find any solution where the MQTT tags automatically save history.

I dont like to put configuration like that out on the MQTT equipment.

What we do to sentralize the managment, is to make reference tags to all MQTT tags. Or even better, an UDT that encapsulate all data from each MQTT device. Then the UDT containing several reference tags, will have history enabled, as well as alarms, or “tag change event” scripts.

Now, everytime a new MQTT device connects to the broker, we manually add one UDT tag, and the configuration is finished (and centralised).

I think i found out why history enabled was not possible. See the screenshot below:

Will try to remove the filter later